Jump to content
Sign in to follow this  

activation page for wf 2850 shows blank

Recommended Posts

updated my wf 2850 firmware --- it shows BL05K now.

tried the activation software that was downloaded from  INKCHIP.

It shows the activation software being upgraded.(see pic - "ink.jpg" below).. till 100% then shutdown. 

It will say, restart the activation software.  When I restart it   --- it shows nothing, no printer USB etc ( see "ink2.jpg"

Been trying this for 3 days.  (downloaded new activation software, deleting the old software)  ... still cant reach its server or something.

tried on different computer ... also tried testing telnet (which is working)


So what is the activation software issue, admin please help?



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...