Jump to content
INKCHIP - Chipless & Adjustment Program Solution

Recommended Posts

I purchased a key for my Epson WF-2830 with order #9837 and ran the firmware program last night. It went to 100% without any error and I turned the printer off and on again. After that, a statement appeared:  "A new firmware is released. Update the firmware from Setup menu"

The printer is not chipless!  I tried to re-run the firmware program with the same result. The firmware now is: 02.38.AL05K3 I could not save the key information.

Please help.


Share this post

Link to post
Share on other sites

Please repeat the entire installation process again.
If there are any errors again, please send us a screenshot.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...