Jump to content

Recommended Posts

I just purchased all the needed items to convert my system to chipless using a CISS. I have an Epson WF-2750. I have tried booting it up in the program mode and running the firmware installation. The program shows that the firmware was uploaded but the printer is stuck on the screen shown. It has been on this same screen for almost an hour now. The power light is flashing blue and the screen is not changing. I tried to run the firmware update by booting the printer normally as well and get a failure screen on the installation. 

No description available.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...