Jump to content
INKCHIP - Chipless & Adjustment Program Solution
Sign in to follow this  

Epson Xp 15000 firmware install failed

Recommended Posts

I have tried every thing I can think of. I start the update after powering on and off with usb cable. Printer says updating reboots sits their doing nothing for almost 15 min waiting on PC to finish first time it went to sleep so thought that might be it reason for the fail changed sleep to 15 min tried again. After failing it tells me their is a firmware update and if I update and try again it still fails then tells me on printer their is a firmware update again I can still print stuff when I pulled up the activation software it did an auto update I think then popped up a screen in another language clicked the mystery button guessing it said OK. It closed and moved the icon across the screen so update? Lol. Than it generates info and will let me input the code but don't want to use it if it's not going to work!

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...